[ClusterLabs] Coming in Pacemaker 1.1.17: container bundles

Ken Gaillot kgaillot at redhat.com
Fri Jun 30 13:46:29 EDT 2017


On 06/30/2017 12:10 PM, Valentin Vidic wrote:
> On Fri, Mar 31, 2017 at 05:43:02PM -0500, Ken Gaillot wrote:
>> Here's an example of the CIB XML syntax (higher-level tools will likely
>> provide a more convenient interface):
>>
>>  <bundle id="httpd-bundle">
>>
>>   <docker image="pcmk:httpd" replicas="3" />
> 
> Would it be possible to make this a bit more generic like:
> 
>   <container type="docker" image="pcmk:httpd" replicas="3" />
> 
> so we have support for other container engines like rkt?

The challenge is that some properties are docker-specific and other
container engines will have their own specific properties.

We decided to go with a tag for each supported engine -- so if we add
support for rkt, we'll add a <rkt> tag with whatever properties it
needs. Then a <bundle> would need to contain either a <docker> tag or a
<rkt> tag.

We did consider a generic alternative like:

  <container type="docker">
     <meta_attributes id="docker-meta">
         <nvpair id="docker-meta-1" name="image" value="pcmk:httpd"/>
         ...
     </meta_attributes>
     ...
  </container>

But it was decided that using engine-specific tags would allow for
schema enforcement, and would be more readable.

The <network> and <storage> tags were kept under <bundle> because we
figured those are essential to the concept of a bundle, and any engine
should support some way of mapping those.




More information about the Users mailing list